Receiver Bugs under Linux (Ubuntu)

The place to discuss all things Receiver.
Post Reply
ghalfacree
Posts: 1
Joined: Fri Nov 16, 2012 4:27 am

Receiver Bugs under Linux (Ubuntu)

Post by ghalfacree » Fri Nov 16, 2012 4:35 am

I'm playing Receiver RC7 under Ubuntu, using the native 64-bit executable, and I've noticed a couple of issues. First, the 'advanced help' doesn't work: pressing ? (or /, for that matter) brings up help, but holding it down just causes the standard help screen to rapidly display and then disappear over and over again. As a result, I'm damned if I can work out how to put the bullets I've been picking up into my empty magazines - any help?

Second, and this may not be a 'bug', but the graphics engine seems a bit screwy: if I'm looking at anything with coloured lighting from a medium distance away, it's made up of giant squares. As I walk towards it, these squares disappear and the surface looks normal. Back away, and the squares are back. I've captured a mild version of it in a screenshot:
Image

So, my questions: how do I put bullets in magazines, what else am I missing from the advanced help screen, and are the blocks normal?

User avatar
Anton
pretty cool guy
Posts: 3327
Joined: Fri Oct 17, 2008 10:16 pm
Location: Los Angeles
Contact:

Re: Receiver Bugs under Linux (Ubuntu)

Post by Anton » Sat Nov 17, 2012 12:27 pm

Reloading bullets into a magazine shouldn't be in the advanced section (although, it's sad you can't reach the advanced section). To reload the magazine, eject the magazine (E), then holster the gun (`)/(~), then place bullets in the magazine (Z) (each bullet manually), un-holster your gun (`)/(~) again, place the magazine in your gun (Z) - you may then need to release the slide lock (T), or cock the gun (R).

User avatar
dyrvere
Posts: 26
Joined: Tue Sep 14, 2010 2:13 am

Re: Receiver Bugs under Linux (Ubuntu)

Post by dyrvere » Wed Nov 21, 2012 8:54 am

Easy one. Open up your command-line and type "setxkbmap us" without quotes, then the holster button should be the one that prints ` (above tab and next to 1 for me) when you type into Xorg apps.
BTW if your desktop environment has an application\systemsetting to add and change mappings it's much easier. :) Which leads me to another fix for the advanced help screen. Setting repeat of keys to off IIRC the jumping\mantle in System Shock 2 didn't work until I did this. Not sure how to do this through CLI commands but in KDE it's in SystemSettings>Input Devices>Keyboard Repeat with the options On|Off|Leave Untouched Try to set it to off.

But for the future I would prefer if it could be changed to H to holster instead of using tilde, more common to use it for a command console within the games.

eventingmonkey
Posts: 2
Joined: Sat Dec 28, 2013 11:39 am

Re: Receiver Bugs under Linux (Ubuntu)

Post by eventingmonkey » Sun Dec 29, 2013 2:23 am

dyrvere wrote:BTW if your desktop environment has an application\systemsetting to add and change mappings it's much easier. :) Which leads me to another fix for the advanced help screen. Setting repeat of keys to off IIRC the jumping\mantle in System Shock 2 didn't work until I did this. Not sure how to do this through CLI commands but in KDE it's in SystemSettings>Input Devices>Keyboard Repeat with the options On|Off|Leave Untouched Try to set it to off.
It is very easy to do this in Ubuntu via System Settings > Keyboard > Key presses repeat when key is held down.
Last edited by eventingmonkey on Sun Dec 29, 2013 2:25 am, edited 1 time in total.

Post Reply