problem with PenumbraOverture on Fedora 12 x86_64

Anything related to Wolfire Games and/or its products
Post Reply
sigru
Posts: 2
Joined: Wed May 12, 2010 7:42 pm

problem with PenumbraOverture on Fedora 12 x86_64

Post by sigru » Wed May 19, 2010 4:49 am

Hello.
I run
[[email protected] PenumbraOverture]$ pwd
/usr/local/games/PenumbraOverture
[[email protected] PenumbraOverture]$ LANG= ./penumbra
./penumbra.bin: ./lib/libCgGL.so: no version information available (required by ./penumbra.bin)
./penumbra.bin: ./lib/libCg.so: no version information available (required by ./penumbra.bin)
ALSA lib pcm.c:2171:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
libgcc_s.so.1 must be installed for pthread_cancel to work
./penumbra: line 9: 13204 Aborted ./penumbra.bin "[email protected]"
Penumbra: Overture exited unexpectedly, please check
/home/ivan/.frictionalgames/Penumbra/Overture/hpl.log
for any error messages
Also try running
ulimit -c unlimited
And re-running Penumbra and try and recreate the error
then submit the generated core file or stack trace

[[email protected] PenumbraOverture]$ ll /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
-rwxr-xr-x 1 root root 20500 Янв 15 02:30 /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
[[email protected] PenumbraOverture]$ rpm -qal |grep libgcc_s.so.1
/lib/libgcc_s.so.1
/lib64/libgcc_s.so.1
[email protected] PenumbraOverture]$ cat /home/ivan/.frictionalgames/Penumbra/Overture/hpl.log
-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 1280 x 1024 - 32 bpp
Init Glee...OK
Setting up OpenGL
Max texture image units: 32
Max texture coord units: 8
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 16
Multisampling: 1
Vertex Program: 1
Fragment Program: 1
NV Register Combiners: 1
NV Register Combiners Stages: 8
ATI Fragment Shader: 0
Creating graphic systems
Creating Renderer2D
Renderer2D created
Creating Renderer3D
Load Renderer3D gpu programs:
Extrude
CG: 'ShadowExtrude_vp.cg' using profile: 'gp4vp'
CG: 'ShadowExtrude_fp.cg' using profile: 'gp4fp'
Diffuse Vertex
CG: 'Diffuse_Color_vp.cg' using profile: 'gp4vp'
Diffuse Fragment
CG: 'Diffuse_Color_fp.cg' using profile: 'gp4fp'
Fog
CG: 'Fog_Solid_vp.cg' using profile: 'gp4vp'
CG: 'Fog_Solid_fp.cg' using profile: 'gp4fp'
Creating fog textures: Solid Additive Alpha
CG: 'refract_vp.cg' using profile: 'gp4vp'
CG: 'refract_fp.cg' using profile: 'gp4fp'
CG: 'refract_special_fp.cg' using profile: 'gp4fp'
init sky box
Renderer3D created
Creating screen buffers size 1280.000000 : 1024.000000
Creating programs
CG: 'PostEffect_Blur_vp.cg' using profile: 'gp4vp'
CG: 'PostEffect_Blur_Rect_fp.cg' using profile: 'gp4fp'
CG: 'PostEffect_Blur_2D_fp.cg' using profile: 'gp4fp'
CG: 'PostEffect_Bloom_vp.cg' using profile: 'gp4vp'
CG: 'PostEffect_Bloom_fp.cg' using profile: 'gp4fp'
CG: 'PostEffect_Motion_vp.cg' using profile: 'gp4vp'
CG: 'PostEffect_Motion_fp.cg' using profile: 'gp4fp'
CG: 'PostEffect_DoF_vp.cg' using profile: 'gp4vp'
CG: 'PostEffect_DoF_fp.cg' using profile: 'gp4fp'
RendererPostEffects created
Adding engine materials
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL.
Trying to open audio device...

Can anybody help me?
Thank you.

User avatar
tomascokis
Posts: 431
Joined: Mon Jan 19, 2009 8:34 pm
Location: Australia, Perth
Contact:

Re: problem with PenumbraOverture on Fedora 12 x86_64

Post by tomascokis » Wed May 19, 2010 10:46 am

I'm afraid you have the wrong forum, you must be after

http://www.frictionalgames.com/forum/forum-20.html

sigru
Posts: 2
Joined: Wed May 12, 2010 7:42 pm

Re: problem with PenumbraOverture on Fedora 12 x86_64

Post by sigru » Wed May 19, 2010 4:08 pm

tomascokis wrote:I'm afraid you have the wrong forum, you must be after

http://www.frictionalgames.com/forum/forum-20.html
Thank you.

Post Reply