Page 1 of 1

No commands

Posted: Mon Mar 21, 2011 8:24 pm
by Jakeukalane

i have a problem with the command line, i can't enter at all in the commands. I tried (with shift+m and without it) ~, `, Ñ, ñ, ö, ` ' +... and a lot more but although i can enter to the debug mode I can't enter to the command line.

I use Linux and i have a complete and registred version of Lugaru HD. I change the config file in the folder of the game and in the /home/user/.lugaru/Data/config.txt
i edit with gedit which it was a plain editor

I have a spanish keyboard but i have been able to set USA and UK keyboard without succed to enter the command line.

So in the IRC some people told me that i must have a line like this: comand key: or something like that but i haven't.

Here is my config file:

Well I think i am doing something stupid that i don't realized before so that's because i want help....

So i never seen the command and maybe i just overlook... Can someone post a screenshot??

Thank you
ps. sorry for the bad english

Re: No commands

Posted: Tue Mar 22, 2011 8:43 am
by Kicktar
I believe the file you want to edit is located in somewhere like C:/Program Files/Lugaru HD/Data/Config.txt although the location varies depending on your OS, so I don't know where it is on Linux, but it should be in a similar place.

Re: No commands

Posted: Wed Mar 23, 2011 1:52 pm
by Jakeukalane
Yep I tried the two places, one /home/user/.lugaru/Data/config.txt and /home/user/.../Games/Lugaru/Data/config.txt and no works

althougt is strange that shift+m works perfectly in order to turn on the debug mode but i can't enter comand line with none of the keys (i tried all of the wiki and a lot more)

Can someone post a screenshot with the command line while is shown?

Thank you

Re: No commands

Posted: Wed Mar 23, 2011 2:23 pm
by Spinnacre

Here is the console.
Your config file looks good, there is no "open console" key specified in my file.
If you are really desperate, I guess you could try modifying the source code and compiling the game yourself.

I don't think I can help you any further, good luck :)

Re: No commands

Posted: Wed Mar 23, 2011 4:06 pm
by Jakeukalane
I think the problem is some confusion between the keyboard and the program since i run the windows version through wine and i can run the command mode, but with a key that isn't ~ (tilde key) or ' at all. this key is in the same position like the USA key for ~ (tilde key).... it think is weird...
i will tray again with different keyboard configuration but if this don't work i will try to compilate the source.
if none of that works finally i think i will do with wine :?

For the people that have the same problem one workarround with the source version can be founded here→
And i am follow this instructions to compile lugaru→

Takk for the help.

Edit: i have too much errors from the compilation. i give up. maybe lugaru without command line is it fun too.

Edit 2: The error is that one→