Running Lugaru on a Mac

The place to discuss all things Lugaru.
Post Reply
Posts: 5
Joined: Sun May 07, 2006 3:34 pm

Running Lugaru on a Mac

Post by Palish » Sun May 07, 2006 3:36 pm

Hey all,

I'm at my friend's house, and he has a mac computer. I downloaded the lugaru demo version for the mac, and unzipped it, and there were two folders. _MACOSX and Lugaru. I opened up Lugaru, and there's a file "Lugaru" in that folder. I double click it, but it says it doesn't know how to open that file.

This isn't my computer, and I've barely used macs before. Real mac newbie. Is there something special I need to do to get the program to run?


Posts: 5
Joined: Sun May 07, 2006 3:34 pm

Post by Palish » Sun May 07, 2006 3:37 pm

Also, I know this computer is Mac OSX.

Posts: 5
Joined: Sun May 07, 2006 3:34 pm

Post by Palish » Sun May 07, 2006 3:39 pm

Some other helpful info:

Mac OS X
Version 10.3.9
466 MHz PowerPC G4

Homocidal Ham
Posts: 44
Joined: Sat Oct 08, 2005 2:11 pm
Location: behind you (muahahahaha)

Post by Homocidal Ham » Sun May 07, 2006 4:34 pm

I have a mac but I never had that problem

but of coarse i downloaded it off a disk

Ill check out the web demo

(note to dave: no I didn't steal lugaru, I bought the registraton code
and the thing i downloaded was a demo)

The Postman
Posts: 1589
Joined: Thu Feb 23, 2006 10:43 pm
Location: Santa Clara,CA

Post by Zantalos » Sun May 07, 2006 5:43 pm

Where did you download this? At Did you click on the mac version? Did you open up the MacOSX and run any of those files? Is there a installer anywhere, there was in the windows port. I don't know what's wrong, it can't be the system requirements, you must not have downloaded or clicked the right thing.

Somebody go step by step on what to do.

User avatar
Support Ninja Master
Posts: 518
Joined: Thu Dec 22, 2005 1:53 am
Location: San Francisco, CA

Post by Eric » Sun May 07, 2006 7:47 pm

I haven't used a Mac in a while (my brother jacked my ibook about 3 months ago), but if i recall correctly you need to copy the main file into the applications folder, everything else will take care of itself. That is how most mac installations work, I don't recall how Lugaru's install worked back in the day when I did it.

Posts: 5
Joined: Sun May 07, 2006 3:34 pm

Post by Palish » Mon May 08, 2006 12:27 am

Well, don't know what's wrong. Tried a few things.

What I did, in order, was this:

Step 1), lugaru, download the "mac demo version". I don't know if there's more than one, but I just did the one on the main lugaru page.

Step 2) Extract. This creates a folder, "LugaruMac Folder". Inside this folder are two folders, "__MACOSX", and "Lugaru". This is where it's weird. Inside of __MACOSX is ANOTHER folder named "Lugaru", and it has all the sub-folders that you'd expect with the installation of Lugaru, except they're all empty, every one of them. I don't even know what to make of it... so I'm just ignoring the __MACOSX folder all together.

This is a little confusing, so let me illustrate:

Hierarchy (Folders Only):

-__MACOSX // This folder and all of its sub folders are empty.
-Lugaru // This folder and its sub folders are not empty.

Anyway, ignoring that the __MACOSX folder and its sub folders are empty, we move on to the OTHER "Lugaru" folder. Inside it is Data and Screenshots folders, and also the files:

Register now!.webloc
Online Manual.webloc

I'm guessing that "Lugaru" is the main file. When I double click it, it pops up saying "There is no default application specified to open the document Lugaru". So I click cancel, and rename it to Lugaru.exe, and run it again. (I don't know if exe is even valid on a mac, I just tried it). I double click it, and nothing happens. Nothing runs, but no error messages either. Then I rename it to and try it again. Same thing. Then I rename it to just plain Lugaru again, copy it to the applications folder like the previous poster suggested, and I get the same error "No default application to open the document..."

So at this point I'm pretty much lost. I went through Config in the Data folder and changed everything I could to 0's, and changed immediate mode to 1, and tried again with it named, but still nothing. Maybe this version was made for mac OS9 and the one I need is in the __MACOSX folder, but it's totally missing? I don't know, I'd have to talk to the developer.

Any help would be awesome.


User avatar
Indecisive titler
Posts: 1935
Joined: Thu Mar 10, 2005 8:54 am
Location: Stockholm, Sweden

Post by Crill3 » Mon May 08, 2006 3:32 am

That happens when you extract with that silly system built in "BOM"-something-thingy.

Get the latest version of Stuffit Expander and use it instead and it
should give you a folder called "Lugaru" with the data folder, launcher
and readme, all with proper icons and the game launchable.

Also the same program should work in both OS9 & OSX (it's not an .app but an app (application))

Posts: 5
Joined: Sun May 07, 2006 3:34 pm

Post by Palish » Tue May 09, 2006 11:15 am

Worked out awesome :) the new version of stuffit worked. Thanks a lot.

Post Reply