No Sound and Textures on Ubuntu 10.10

The place to discuss all things Lugaru.
Post Reply
stremi
Posts: 3
Joined: Sun Apr 18, 2010 10:31 am

No Sound and Textures on Ubuntu 10.10

Post by stremi » Sun Dec 05, 2010 7:12 am

Hi there,

today I installed ubuntu 10.10 on my computer. I used windows before. My brother loves Lugaru, so I have to install it :D

I've downloaded the Linux-Version and installed it with the terminal:

[email protected]:~/Downloads$ chmod +x lugaru-full-linux-x86-1.0c.bin
[email protected]:~/Downloads$ lugaru-full-linux-x86-1.0c.bin

It was successful, but Lugaru doesn't look like the Windows-Version. I cant hear any sounds and the textures (inc. the Map), except the scrubs and rabbits are just white, but you can see the shaddow...

[email protected]:~/lugaru$ sudo ./lugaru
open /dev/[sound/]dsp: No such file or directory
open /dev/[sound/]dsp: No such file or directory
open /dev/[sound/]dsp: No such file or directory

(I hope you can understand my english)

stremi

edit:
Same problem by starting the windows-files with wine. But sound works :D (And íts faster as in the real windows oO)

User avatar
Madd the Sane
Posts: 197
Joined: Sat Apr 16, 2005 3:57 pm
Location: Mac universe
Contact:

Re: No Sound and Textures on Ubuntu 10.10

Post by Madd the Sane » Wed Dec 08, 2010 5:29 am

The audio problem is known, just look around the forums a bit and you'll find the solution. As for the visual issue, try to see if there is a third-party driver available. Ubuntu is good to tell you if there is one. Also, listing your specs would help.

User avatar
meklu
Posts: 6
Joined: Sun Dec 26, 2010 12:37 pm
Location: Helsinki, Finland

Re: No Sound and Textures on Ubuntu 10.10

Post by meklu » Sun Dec 26, 2010 12:48 pm

If your problem hasn't gone away yet I recommend you to launch the Linux version with the following command in the install directory:

Code: Select all

padsp ./lugaru
P.S. You really shouldn't use sudo when you run something which doesn't need root.

HolyHandGrenade
Posts: 1
Joined: Wed Dec 29, 2010 11:06 am

Re: No Sound and Textures on Ubuntu 10.10

Post by HolyHandGrenade » Wed Dec 29, 2010 11:09 am

meklu wrote:If your problem hasn't gone away yet I recommend you to launch the Linux version with the following command in the install directory:

Code: Select all

padsp ./lugaru
P.S. You really shouldn't use sudo when you run something which doesn't need root.
Yeah, running Lugaru as sudo probably screwed up permissions. You'll have to chown it to fix those.

I've also got Ubuntu 10.10 (Mint 10 actually but it's the same thing). I'd suggest just using the Windows version in Wine; it's much better. Otherwise 'padsp ,/lugaru' will usually work, but that got some pretty rough audio on my system.

jmaasing
Posts: 1
Joined: Fri Dec 30, 2011 5:35 am

Re: No Sound and Textures on Ubuntu 10.10

Post by jmaasing » Fri Dec 30, 2011 5:41 am

Since there is no linux alpha of overgrowth I decided to have a look at the demo of lugaru. Downloaded it yesterday. Have the exact same issues on Debian 6.
Sound was solved by installing "oss-compat", I am using ALSA and therefore have no /dev/dsp devices by default.
But the visuals are strange. I see shadows, skybox, terrain and footprints but no models whatsoever. Running nVidia (the 290 version of their driver).

So no overgrowth and no lugaru, guess I'll have to check this out some other year :(

Post Reply